RFC7208 — Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1

provenance: imported · standards: RFC7208

RFC7208: Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1

IETF Request for Comments

Status PROPOSED STANDARD
Publication status PROPOSED STANDARD
Published April 2014
Stream IETF
Obsoletes RFC4408
Obsoleted by —
Updated by RFC7372, RFC8553, RFC8616

Abstract

Email on the Internet can be forged in a number of ways. In particular, existing protocols place no restriction on what a sending host can use as the "MAIL FROM" of a message or the domain given on the SMTP HELO/EHLO commands. This document describes version 1 of the Sender Policy Framework (SPF) protocol, whereby ADministrative Management Domains (ADMDs) can explicitly authorize the hosts that are allowed to use their domain names, and a receiving host can check such authorization. This document obsoletes RFC 4408.

Official sources

  • Info page: https://www.rfc-editor.org/info/rfc7208
  • Full text: https://www.rfc-editor.org/rfc/rfc7208.txt
  • HTML: https://www.rfc-editor.org/rfc/rfc7208.html

Abstract and metadata are reproduced from the public RFC index; the full text is linked, not copied.

See all 29 pages under Internet standards (RFC) →

Related pages